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ภายหลังจากที่ได้มีการสร้างแอนิเมชันในรูปแบบต่างๆ ขึ้นมาแล้ว เราอาจมีความต้องการที่จะน า
ผลงานเหล่านั้นมาท าการเชื่อมโยงไปมา เช่น เมื่อคลิกที่ปุ่มใดๆ แล้วก าหนดให้เชื่อมโยงปรากฏผลงาน
แอนิเมชันอีกผลงานหนึ่งที่ได้สร้างไว้ขึ้นมา ก าหนดให้เชื่อมโยงไปยัง เว็บไซต์ใดๆ ที่ต้องการ หรือก าหนดให้
เชื่อมโยงไปยังซีนข้อมูลอีกซีนหนึ่งก็ได้เช่นกัน และเมื่อท าการใส่ ActionScipt ก็จะท าให้ผลงานมีความ
สมบูรณ์เต็มเปี่ยมด้วยประสิทธิภาพมากยิ่งขึ้น  
 ส าหรับในเรื่องนี้เราจะได้เรียนรู้ขั้นตอนการสร้างแอนิเมชันในรูปแบบใหม่ ๆ โดยอาศัยพ้ืนฐานของ
เรื่องก่อนหน้านี้ พร้อมทั้งท าการเชื่อมโยงผลงานแอนิเมชันเหล่านั้นเข้าด้วยกัน และเพ่ือให้ผลงานมีความ
สมบูรณ์มากยิ่งขึ้น เราจะได้เรียนรู้ ค าสั่ง ActionScipt เบื้องต้น ที่ใช้ควบคุมก าหนดการท างานด้านต่างๆ 
ให้กับผลงาน เช่นก าหนดให้หยุดเล่นผลงาน แอนิเมชันเมื่อถึงเฟรมที่ก าหนด ก าหนดให้เชื่อมโยงไปยังเว็บไซต์
ต่างๆ  

ผลงานที่สร้างขึ้นภายในอาจมีการเชื่อมโยงข้อมูลมากมายจนกลายเป็นผลงานชิ้นหนึ่งขึ้นมา  
เช่น อาจมีการสร้างปุ่มขึ้นมาให้ผู้เข้าชมได้ใช้ส าหรับคลิกโต้ตอบ เพื่อเชื่อมโยงไปยังข้อมูลหรือเว็บไซต์ต่างๆ ซึ่ง
การท างานดังกล่าวเป็นการท างานในลักษณะ Interactive 
       ส าหรับตัวอย่างต่อไปนี้จะท าการสร้างเลเยอร์ขึ้นมา 3 เลเยอร์ โดยเลเยอร์ที่ 1 เป็นไฟล์ภาพรูปภาพ
พร้อมกับปุ่มคลิก 1 ปุ่ม เลเยอร์ที่ 2 เป็นไฟล์ภาพพร้อมกับปุ่มคลิก 2 ปุ่ม และเลเยอร์ที่ 3 สร้างขึ้นเพ่ือใช้
ส าหรับสั่งค าสั่ง Actions ต่างๆ เช่น ค าสั่ง stop ที่ใช้ในการหยุดแสดงข้อมูลเมื่อถึงเฟรมที่ก าหนด ค าสั่ง goto 
เพ่ือให้เล่นไปยังเฟรมท่ีก าหนดเมื่อมีการคลิกเมาส์เกิดขึ้น รวมถึงสั่งให้เชื่อมโยงไปยังเว็บไซต์ที่ก าหนดไว้ 
 ลักษณะการท างานคือ เมื่อมีการคลิกปุ่มที่อยู่ในเลเยอร์ 1 จะให้ท าการเชื่อมโยงไปยังเลเยอร์ 2 และ
เมื่อมีการคลิกบนปุ่มที่ 1 ของเลเยอร์ 2 จะให้กลับสู่เลเยอร์ 1 แต่หากคลิกปุ่มที่ 2 แทน ก็จะให้ท าการ
เชื่อมโยงไปสู่เว็บไซต็ที่ก าหนดไว้ 

1. คลิกเมนูค าสั่ง File เลือกค าสั่ง Import และ Import to Stage เพ่ือน าไฟล์รูปภาพที่ 1 ที่
ต้องการเข้ามาใช้งาน 

2. คลิกเมาส์ขวาเฟรมที่ 5 และเลือกค าสั่ง Insert frame เฟรมทั้งหมดจะมีความยาวจ านวน 5 
เฟรม 
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3. ดรากส์เมาส์สร้างปุ่ม 1 ปุ่ม เพื่อใช้คลิกไปสู่ไฟล์ภาพที่ 2  
4. คลิกปุ่ม Insert Layer  ที่ไทม์ไลน์ นั้นจะปรากฏเลเยอร์ใหม่ ( คือ เลเยอร์ 2 ) ขึ้นมาจ านวน 1 

เลเยอร์ 
5. คลิกเมนูค าสั่ง File เลือกค าสั่ง Import และ Import to Stage เพ่ือน าไฟล์ภาพที่ 2 ที่ต้องการ

เข้ามาใช้งาน จากนั้นไฟล์ภาพที่ 2 จะวางซ้อนทับอยู่บนไฟล์ภาพที่ 1 
 
 
 
 

คลิกเมนู File > Import 

คลิกเมาส์ขวาเฟรมที่ 5 และ
เลือกค าสั่ง Insert Frame 
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6. ดรากส์เมาส์สร้างปุ่ม 2 ปุ่ม เพื่อใช้คลิกไปสู่ไฟล์ภาพที่ 1 และคลิกไปสู่เว็บไซต์ที่ก าหนด 
7. ดับเบ้ิลคลิก Layer 2 และดรากส์เมาส์ลากมาไว้เฟรมที่ 10 เพ่ือวางภาพที่ 2 ในเลเยอร์ 2 ต่อท้าย

ชิ้นงาน (ภาพท่ี 1) ในเลเยอร์ที่ 1 
8. คลิกปุ่ม Insert Layer   ที่ไทม์ไลน์ จากนั้นจะปรากฏเลเยอร์ใหม่ (คือ Layer 3 ) ขึ้นมา

จ านวน 1 เลเยอร์ 
9. คลิกเมนูค าสั่ง Window  เลือกค าสั่ง Development Panels เลือก Actions ให้ปรากฏ

เครื่องหมายถูก จากนั้นจะปรากฏ Actions Panel ขึ้นมา 
 

ดรากสเ์มาส์สร้างปุ่ม 1 ปุ่ม 

คลิกปุ่ม Insert Layer 

คลิกเมนู File > Import 
> Import to Stage  
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10. คลิกเลือก Global Function แล้วเลือก Timeline control แล้วเลือกค าสั่ง Stop ดับเบิ้ลคลิกที่
ค าสั่ง stop เพ่ือหยุดการแสดงผลเมื่อเล่นมาถึงเฟรมนี้ 

 

ดับเบิ้ลคลิก Layer 2 จากนั้นให ้
ดรากสเ์มาส์ลากมาไวเ้ฟรมที่ 10 

ดรากสเ์มาส์สร้างปุ่ม 2 ปุ่ม 

คลิกปุ่ม Insert Layer 

คลิกเมนู  Window > Actions 
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11. คัดลอกค าสั่ง stop จากเฟรมที่ 1 มาไว้เฟรมที่ 5 เพื่อก าหนดจุดหยุดของข้อมูลเฟรมสุดท้ายในเล

เยอร์ที่ 1 
12. คัดลอกค าสั่ง stop จากเฟรมที่ 1 มาไว้เฟรมที่ 10 เพ่ือก าหนดจุดหยุดของข้อมูลใน 

เลเยอร์ที่ 2 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

13. กลับมาที่เลเยอร์ที่ 1 คลิกปุ่ม ซึ่งแสดงเป็นช่วงจังหวะในการแสดงข้อมูลในเลเยอร์ที่ 2  
14. คลิกเลือก Global function เลือก Movie Control แล้วดับเบิ้ลคลิกค าสั่ง on แล้วใส่ค่าใน

วงเล็บเป็น release  

คัดลอกค าสั่ง stop  
มาไว้เฟรมที่ 5 

ดับเบิ้ลคลิกท่ีค าสั่ง stop 

ดรากสเ์มาส์ค าสั่ง stop มาไว้เฟรมที่ 10 
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15. แล้วคลิกเลือก Global function เลือก Timeline Control แล้วดับเบิ้ลคลิกค าสั่ง 
gotoAndPlay เพ่ือก าหนดการท างานหลังจากคลิกที่ปุ่มแล้ว 

16. ในวงเล็บให้พิมพ์หมายเลขเฟรมเป็น 10 เมื่อคลิกที่ปุ่มก็จะเชื่อมโยงเข้าสู่เฟรมที่ 10 ในเลเยอร์ที่ 
2  ตัวอย่าง gotoAndPlay (10) เป็นต้น 

 
 
 
 
 
 
 
 

17. คลิกปุ่มที่ 1 ใน Layer 2 
18. คลิกเลือก Global function เลือก Movie Control แล้วดับเบิ้ลคลิกค าสั่ง on แล้วใส่ค่าใน

วงเล็บเป็น release  
19. แล้วคลิกเลือก Global function เลือก Timeline Control แล้วดับเบิ้ลคลิกค าสั่ง 

gotoAndPlay เพ่ือก าหนดท างานหลังจากคลิกที่ปุ่มแล้ว 
20. ในวงเล็บให้พิมพ์หมายเลขเฟรมเป็น 1 เมื่อคลิกที่ปุ่มก็จะเชื่อมโยงเข้าสู่เฟรมที่ 1 ใน  เลเยอร์ที่ 1

ตัวอย่าง gotoAndPlay (1) เป็นต้น 
 
 

คลิกท่ีปุ่ม ในเลเยอร์ที่ 1  

ดับเบิ้ลคลิกท่ีค าสั่ง on เลือก release 

ดับเบิ้ลคลิกที่ค าสั่ง gotoAnd Play พิมพ์หมายเลขของเฟรม 
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21. คลิกปุ่มที่ 2 ใน Layer 2  
22. คลิกเลือก Global function เลือก Movie Control แล้วดับเบิ้ลคลิกค าสั่ง on แล้วใส่ค่าใน

วงเล็บเป็น release  
23. คลิกเลือกค าสั่ง Browser/Network  ดับเบิ้ลคลิกที่ค าสั่ง getURL เพ่ือก าหนดเว็บไซต์ที่ต้องการ

เชื่อมโยง 
24. ช่อง URL ให้พิมพ์ชื่อเว็บไซต์ที่ต้องการเชื่อมโยงเป็น http://www.tapraya.ac.th 

 
 
 
 
 
 
 
  
 
 
 
 
 
 
 

คลิกปุ่มที่ 2 

ดับเบิ้ลคลิกท่ีค าสั่ง getURL 

พิมพ์ช่ือเว็บไซต ์

คลกิปุ่ มที่ 1 

ดับเบิ้ลคลิกท่ีค าสั่ง goto 

พิมพ์หมายเลขเฟรม 

“http://www.tapraya.ac.th”); 

http://www.tapraya.ac.th/
http://www.tapraya.ac.th/
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ซีน (Scene) เปรียบเสมือนเรื่องราวของฉากละครแต่ละฉาก ดังนั้นหากต้องการให้ผลงานของ 
เราเป็นที่น่าสนใจยิ่งขึ้น เพียงแค่คลิกเมนูค าสั่ง Insert เลือกค าสั่ง Scene เราก็ได้ซีนใหม่ที่สามารถสร้างข้อมูล
แต่ละฉากได้อีกมากมาย จากนั้นจึงน าซีนเหล่านั้นมาท าการเชื่อมโยงให้เกิดเป็นมูฟวี่ขึ้นมา 

เมื่อน าไปใช้กับอินเทอร์เน็ตมูฟวี่ที่สร้างข้ึนจะถูกแบ่งเวลาในการโหลดภาพออกเป็นช่วงๆ ตาม 
จ านวนซีนที่สร้างไว้ซึ่งส่งผลกับความเร็วในการโหลดข้อมูล เพราะจะท าการโหลดเฉพาะข้อมูลในซีนที่ 1 ขึ้นมา 
และเม่ือเล่นจนถึงเฟรมสุดท้าย หรือมีการคลิกที่ปุ่ม จึงค่อยท าการโหลดข้อมูลในซีนที่ 2 ขึ้นมา 
 

1. ให้เลือกเมนูค าสั่ง File เลือกค าสั่ง Import  เข้ามาไว้บนเฟรมที่ 1 และท าเป็น Symbol  โดย
เลือกเมนูค าสั่ง Insert  เลือกค าสั่ง Convert to Symbol เลือกเป็น Graphic ตั้งชื่อว่า Pic1 
แล้วคลิกท่ีปุ่ม OK  

 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. คลิกเมาส์ขวาเฟรมที่ 10 และเลือกค าสั่ง Insert Keyframe จากนัน้จะปรากฏคีย์เฟรมข้ึนมาบน
เฟรมที่ 10 

1 
ใส่ช่ือ 

เลือกเป็น Graphic 

คลิก OK 
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3. คลิกเมาส์เฟรมที่ 10 และเลือกเมนูค าสั่ง Window เลือกค าสั่งProperties จากนั้นให้คลิกที่
รูปภาพและใน Properties ในช่อง  Color เลือกเป็น Alpha ปรับค่าให้เป็น 0%  

 

 

 
 
 
 
 
 
 
 
 

4. ให้คลิกเมาส์ขวาที่เฟรมที่ 1 เลือกค าสั่ง Create Classic Tween  
 
 
 
 

เลือกเป็น Alpha  

ปรับค่าให้เป็น 0% 



 

โรงเรียนตาพระยา  อ าเภอตาพระยา  จังหวัดสระแก้ว  ส านักงานเขตพื้นท่ีการศึกษามัธยมศึกษา  เขต 7 หน้า 153 

 

 

 
 

5. คลิกเมาส์ขวาที่เฟรมที่ 11 เลือกค าสั่ง Insert Keyframe จะปรากฏ Keyframeขึ้นมา  
6. คลิกเมาส์ขวาที่เฟรมที่ 20 เลือกค าสั่ง Insert Keyframe จากนั้นให้คลิกที่รูปภาพ 1 ครั้ง ให้คลิก

หน้าต่าง Properties ขึ้นมาและตรงช่อง Color เลือกเป็น Alpha ปรับค่าให้เป็น 100% 
 
 
 
 
 
 
 
 
 
 
 
  

7. ให้กลับมาที่เฟรมที่ 11 คลิกเมาส์ขวาที่เฟรมที่ 11 เลือกค าสั่ง Create Motion Tween  

เลือก Alpha 

ปรับค่าให้เป็น 100% 
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8. คลิกเมาส์ขวาที่เฟรมที่ 25 เลือกค าสั่ง Insert Keyframe และสร้างปุ่มบนสเตจขึ้นมา 1 ปุ่ม 
เพ่ือที่จะสามารถคลิกไปยังซีนที่ 2 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

คลิกเมาส์ขวาที่เฟรมที่ 11 
เลือก Create Motion 
Tween 

สร้างปุ่มขึ้นมา 1 ปุ่ม 
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9. สร้าง Layer ขึ้นมา อีก 1 Layer  โดยคลิก      จากนั้นให้คลิกเมาส์ขวาที่เฟรมที่ 25              
ในเลเยอร์ที่ 2เลือกค าสั่ง Insert Keyframe เพ่ือที่ใส่ค าสั่งในเฟรมนี้ 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

10. ให้เลือกเมนคู าสั่ง Window เลือกค าสั่ง  Actions  
11. เลือกค าสั่ง Global Functions แล้วเลือก Timeline Control และดับเบิ้ลคลิกที่ค าสั่ง Stop 

เพ่ือที่จะให้ภาพเคลื่อนไหวหยุดเฟรมที่ 25 ให้เราสามารถที่จะคลิกปุ่มที่สร้างขึ้นเพ่ือเชื่อมโยงไป
ยังซีนที่ 2 

 
 
 
 
 
 
 
 
 
 
 
 

คลิกเพื่อสร้างเลเยอร์ใหม ่

คลิกเมาส์ขวาท่ีเฟรมที่ 25 
เลือก Insert Keyframe 

ดับเบิ้ลคลิกท่ีค าสั่ง Stop 

คลิกเลือกเฟรมที่ 25 

ค าสั่ง Stop 

ค าสั่งจะปรากฏใน 
Frame ที่ 25 
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12. คลิกเลือกปุ่มที่จะใส่ค าสั่งเพื่อเมื่อคลิกแล้วข้ามไปเล่นในซีนที่ 2  
13. คลิกเลือก Global function เลือก Movie Control แล้วดับเบิ้ลคลิกค าสั่ง on แล้วใส่ค่าใน

วงเล็บเป็น release  
 
 
 
 
 
 
 
 
 
 
 
 

14. แล้วคลิกเลือก Global function เลือก Timeline Control แล้วดับเบิ้ลคลิกค าสั่ง 
gotoAndPlay เพ่ือก าหนดท างานหลังจากคลิกที่ปุ่มแล้ว 

15. ในวงเล็บให้พิมพ์ชื่อ Scene เมื่อคลิกที่ปุ่มก็จะเชื่อมโยงเข้าสู่ Scene ที่ 2 ในเฟรมที่ 1 ตัวอย่าง 
gotoAndPlay (“Scene 2”, “1”) เป็นต้น 

 
 
 
 
 
 
 
 
 
 
 
 
 

คลิกท่ีปุ่ม 

คลิกท่ีค าสั่ง on 

ดับเบิ้ลคลิกท่ีค าสั่ง gotoAndPlay 

ใส่ช่ือ Scene และ Frame Number 
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1. คลิกเมนูค าสั่ง  Insert เลือกค าสั่ง Scene จะปรากฏซีนใหม่เพ่ือใช้สร้างข้อมูลที่จะน ามาเชื่อมโยง
เข้าเป็นมูฟวี่ขึ้นมา 

 

 
 

2. คลิกเมนูค าสั่ง Modify เลือกค าสั่ง Document จะปรากฏไดอะล็อกบ็อกซ์ Document 
Properties ขึ้นมา 

3. ที่ Background Color ให้คลิกเลือกค่าสีเทาจากนั้นที่ฉากหลังจะเปลี่ยนเป็นสีเทาและคลิกปุ่ม 
OK เพ่ือยืนยันค าสั่ง 
 

 
 
 
  
 
 
 
 
 
 
 
 
 

4. คลิกเมนู File > Import > Import to Stage เพ่ือน าไฟล์ภาพที่ต้องการขึ้นมา 

คลิกเลือกค าสั่ง Insert > Scene 

คลิก Modify > Document 

เลือกBackground Color 
ให้เป็นสีเทา 
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5. คลิกเมาส์ขวาเฟรมที่ 20 เลือกค าสั่ง Insert Frame  

 
 
 
 
 
 
 
 
 
 
 
 
 

6. คลิกปุ่ม Insert Layer    ที่ไทม์ไลน์ จากนั้นจะปรากฏเลเยอร์ใหม่ขึ้นมา 
 
   
 
 
 
 

7. สร้างออบเจ็กต์ไว้ใน Layer 2  
8. คลิกเมาส์ขวาเฟรมที่ 20 เลือก Insert Keyframe และเลือกค าสั่ง Create Motion Tween 
 
 
 
 
 
 
 
 
 

น าไฟล์ภาพมา 

คลิกเมาส์ขวาเลือก 
Insert Frame  

คลิก Insert Layer 
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9. ดรากส์เมาส์ลากออบเจ็กต์ไปอีกด้านหนึ่งของออบเจ็กต์ที่อยู่ในเลเยอร์ 1 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

คลิกเมาส์ขวาเฟรมที่ 20 เลือก 
Insert Keyframe และ  
Create Classic Tween 

สร้างออบเจ็กต์ในเลเยอร์ที่ 2 

ดรากสเ์มาส์ลากเคลื่อนย้ายออบเจ็กต ์
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10. คลิกเมาส์ขวาที่เลเยอร์ 2 เลือกค าสั่ง Mask จากนั้นออบเจ็กต์ในเลเยอร์ที่ 1 ที่ได้ถูก Mask ไว้อยู่ 

จะปรากฏขึ้นมาเฉพาะบริเวณท่ีออบเจ็กต์ ในเลเยอร์ที่ 2 วางซ้อนทับไว้อยู่เท่านั้น 

 
 
 
 
 
 
 
 
 
 
เมื่อได้ท าการเชื่อมโยนระหว่างซีนเสร็จเรียบร้อยแล้วให้ลองทดสอบดูว่าแต่ละซีนท างานตามปกติ 
โดยลองกดคีย์บอร์ดปุ่ม < Ctrl+Enter > 
 
 

คลิกเมาส์ขวา Layer 2 
เลือกค าสั่ง Mask 

ออบเจ็กต์ที่ 1ได้ถูก Mask ไว้  
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 ผลงานแอนิเมชันที่สร้างขึ้นทั้งหมด เมื่อน าไปแสดงบนเว็บไซต์อาจดูธรรมดาเกินไป ทั้งนี้อาจ
เนื่องมาจากเพราะขาดเสียงดนตรีหรือเสียงเพลงประกอบในระหว่างการแสดงผลงานนั่นเอง ดังนั้นหากมีไฟล์
เพลงอันแสนไพเราะ ก็สามารถน ามาประกอบในผลงานได้ตามต้องการ 
 โดยไฟล์เสียงหรือไฟล์เพลงที่รองรับสามารถน าเข้ามาท างานร่วมกับโปรแกรมได้ อาทิเช่น ไฟล์
นามสกุล >MP3 ที่รองรับกับระบบปฏิบัติการวินโดวส์ ไฟล์นามสกุล .AIFF ที่รองรับส าหรับระบบปฏิบัติการ
แมคอินทอซ ไฟล์นามสกุล .MP3 ที่รองรับกับระบบปฏิบัติการวินโดวส์และแมคอินทอซ 
 แต่ข้อพึงระวังส าหรับการน าไฟล์เสียงมาใช้งาน คือ ผลงานที่ได้จะมีขนาดไฟล์ที่ใหญ่ขึ้น ท าให้อาจ
เปลืองเวลาในการโหลดข้อมูล ดังนั้นจึงควรพิจารณาเมื่อต้องการที่จะน าไฟล์เสียงมาใช้งานประกอบลงใน
ผลงานด้วย และส าหรับในที่นี้ จะขออธิบายวิธีการน าไฟล์เสียงเข้ามาใช้งานได้ 2 รูปแบบ คือ วิธีการน าไฟล์
เสียงลักษณะเป็นดนตรีประกอบตลอดช่องการแสดงผลงาน 

การน าไฟล์เสียงมาประกอบลงในออบเจ็กต์ชิ้นงานต่างๆ ไม่ว่าจะเป็น ปุ่ม ภาพ ข้อความ ฯลฯ  
สามารถท าได้อย่างง่ายดาย โดยไฟล์เสียงที่น าเข้ามาประกอบนั้นอาจเป็นไฟล์เสียงเอฟเฟ็กต์ที่ต้องการให้เล่น
หลังจากมีการท างานต่างๆ เกิดข้ึน 

เพ่ือความสมบูรณ์ของการเคลื่อนไหวที่เราสร้างขึ้น เราสามารถที่จะใส่เสียงประกอบเข้าไปในเฟรมได้อีก
ด้วย โดยเสียงที่จะน ามาใช้ได้นั้นจะต้องถูกจัดเก็บไว้ในไลบรารี่เสียก่อน และต้องแยกอยู่คนละเลเยอร์กับการ
เคลื่อนไหว 

1. ให้เปิดไฟล์งานที่เราสร้างเอาไว้ก่อนหน้านั้นมาแล้วจากนั้นให้ คลิกเมนูค าสั่ง File เลือกค าสั่ง 
Import  แล้วเลือก Import to Library จะปรากฏไดอะล็อกบ็อกซ์ Import to Library ขึ้นมา  

2. ดับเบิ้ลคลิกไฟล์เสียงที่ต้องการเล่นเมื่อมีการคลิกที่ปุ่ม จากนั้นไฟล์เสียงจะถูกเก็บอยู่ใน Library 
Panel  
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3. ใช้ไฟล์เสียงที่โปรแกรมจัดเตรียมไว้ให้ โดยคลิกเลือกเมนูค าสั่ง  Window เลือกค าสั่ง Common 
Libraries เลือกค าสั่ง Sounds  

 

เลือกค าสั่ง File >Import > Import to 
Library 

เลือก Sound ที่ต้องการ 
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4. ในพาเนล TimeLine สร้างเลเยอรใ์หม่ เพ่ือใส่เสียง โดยเลือกเมนคู าสั่ง Insert เลือกค าสั่ง Layer 

ให้ตั้งชื่อว่า Sound    
 

 
 
5. เลือกเลเยอร์ของเสียงนั้น แล้วลากไฟล์เสียงจากพาเนล Library มาใส่ลงในสเตจเสียงนั้นจะถูก

บรรจุเข้าในเลเยอร์ขณะนั้น 
 
 
 
 
 
 

6. ในพาเนล Timeline คลิกท่ีเฟรมของเสียง แล้วตั้งค่าของเสียงได้ในพาเนล Properties 

 
 
 

คลื่นเสียงของไฟล์เสียง 



 

โรงเรียนตาพระยา  อ าเภอตาพระยา  จังหวัดสระแก้ว  ส านักงานเขตพื้นท่ีการศึกษามัธยมศึกษา  เขต 7 หน้า 164 

 

 
 ในส่วนของ Effect เลือกเอ็ฟเฟ็คในการเล่นเสียงตามต้องการ ซึ่งอาจเป็น 
 
 
 
 
 
 
 
 
 
None    ไม่ใส่เอ็ฟเฟ็ค 
Left Channel   เสียงออกเฉพาะล าโพงซ้ายเท่านั้น 
Right Channel  เสียงออกเฉพาะล าโพงขวาเท่านั้น 
Fade Left to Right สลับเสียงจากล าโพงด้านหนึ่งไปยังอีกด้านหนึ่ง  
Fade Right to Right สลับเสียงจากล าโพงด้านหนึ่งไปยังอีกด้านหนึ่ง 
Fade In   เสียงค่อยๆ ดังขึ้น 
Fade Out  เสียงค่อยๆ เบาลง  
Custom   ปรับแต่งเอง 
 
 เลือกการเกิดเสียงจากส่วนของ Sync ซึ่งอาจเป็น 
 
 
 
 
 
Event  เกิดเสียงตามเหตุการณ์ที่เกิดขึ้น เช่น เมื่อคลิกปุ่ม 
Start  เหมือน Event แต่ไม่สามารถเกิดเสียงจากหลายๆอินสแตนซ์พร้อมๆ กันได้ 
Stop  การปิดเสียง 
Stream เกิดเสียงแบบกระแสเสียงที่อ่านไปเล่นไปไม่ต้องรอให้อ่านจบไฟล์ก่อน มักใช้ในเว็บเพจ 
 เราสามารถก าหนดจ านวนรอบในการเกิดเสียงในส่วนของ Loop  
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ในที่นี้ เราจะใส่เสียงให้เฟรมสุดท้ายของ มูฟวี่เรา 
 
 

1. เลือกค าสั่งเมน ูFile เลือกค าสั่ง Import  
แล้วเลือก Import to Library เพ่ือน าไฟล์เสียง 
มาใส่ในไลบรารี่ 

 
 
 
 

2. ในเลเยอร์ Sound คลิกท่ีเฟรมสุดท้าย แล้วเลือกเมนูค าสั่ง Insert เลือกค าสั่ง Keyframe 

 
 

3. ในส่วนของ Sound  ในพาเนล Properties คลิกเลือกเสียงที่ต้องการ 

 
 

ใส่จ านวนรอบท่ีต้องการให้เกดิเสียง 
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สามารถใส่เสียงให้กับปุ่มในภาวะต่างๆ ได้ เช่น ให้เกิดเสียงเมื่อคลิกท่ีปุ่มนั้น ซึ่งจะกระท าได้ดังนี้ 
1. ก่อนอ่ืน จะต้องน าไฟล์เสียงที่จะใช้เข้ามาไว้ในโปรแกรมเสียก่อนด้วยคลิกเลือกค าสั่งเมนู File 

เลือกค าสั่ง Import แล้วเลือก Import to Library เพ่ือน าไฟล์เสียงมาใส่ในไลบรารี่ 
2. ในพาเนล Library เลือกปุ่มที่จะใส่เสียง แล้วดับเบ้ิลคลิกปุ่มท่ีต้องการใส่เสยีง 
3. ในพาเนล Timeline สร้างเลเยอร์ใหม่เพ่ือใส่เสียง ให้ตั้งชื่อว่า Sound 

 
 

4. ในเลเยอร์ของเสียงนั้น ให้คลิกท่ีเฟรมในภาวะที่จะใส่เสียง 
ตัวอย่างเช่น ถ้าต้องการให้เกิดเสียงเมื่อคลิกปุ่ม ให้คลิกท่ีเฟรมตรงภาวะ Down เป็นต้น แล้วให้
คลิกเมาส์ขวาตรงเฟรม Down แล้วเลือกเมนคู าสั่ง Insert เลือกค าสั่งKeyframe  

 
 

 
 
 
 
 
 
 
 
 
 
 

5. ในพาเนล Properties เลือกเสียงในส่วนของ Sound 
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6. ตั้งค่าต่างๆ ในการเกิดเสียง 
 
 
 
 
 
 
 
 
เมื่อก าหนดเสียง ในปุ่มเรียบร้อยแล้วให้ทดสอบค่าโดยลองกดคีย์บอร์ดปุ่ม < Ctrl+Enter > 
 

 
 

เลือกเทคนิคในการเกิดเสียง 

เลือกว่าจะใหเ้กิดเสียงเมื่อใด 

แก้ไขเสยีง 


